Browse by Topic: Security & Reliability
Deprecating TLSv1.0 and TLSv1.1
Last modified on 27 September 2019 07:50 AM

In September 2019, we have disabled TLS versions 1.0 and 1.1 across our web services. These are encryption protocols to access our website. We have made this change to keep our servers safe and secure.

This means you can no longer access our website on older operating systems.

Mobile

  • Android versions 4.4 or lower with Stock browser
  • iOS versions 8.1 or lower with Safari

Desktop

  • Windows with Internet Explorer 10 or lower
  • Mac OS X versions 10.10 or lower with Safari

If you're able to upgrade to a newer version of your operating system this will solve the issue. If the hardware you're using does not allow you to upgrade to a newer version, you may be able to still use the StartMail website by using Mozilla Firefox or Google Chrome instead of Microsoft Internet Explorer (Windows) or Apple Safari (Mac OS X) on these versions.

(2 vote(s))
This article was helpful
This article was not helpful

Still haven't found the answer to your question? Click here to contact support.